Инструкция по установке

1. Скрипт чата может быть установлен как в корень сайта (поддомена, например chat.site.ru), так и в папку домена. Залейте туда файлы из папки __html

2. Создайте таблицы. Запрос находится в папке __sql помощь

Примечание: Условное обозначение ... означает: зависимотсти от того куда Вы распаковали файлы - в корень сайта или в папку, путь будет следующим:

www.вашсайт.ru/...
или
www.вашсайт.ru/папка/...

3. Установите пароли доступа к базе данных в файле

.../config/config.php

4. На файлы

.../admin/.htaccess
.../admin/.htpasswd
.../ajaxscripts/Chat/Chat.php

установите права 666

5. пройдите по адресу

.../admin/admin_chat.php

и установите пароль активации администраторских прав.

ВНИМАНИЕ! Если Вы не сделаете пункты 1, 2 и/или 3, то чат просто не будет работать.
Если не сделать пункты 4 и/или 5, то первое - чат будет неправильно работать, второе - злоумышленник может войти с правами администратора и распугать Вам весь народ.

6. Установите необходимые настройки в файле

.../config/config_chat.php

Приятной работы!

Форум поддержки скрипта
Заказать рекламу (банер) в дистрибутиве чата

Powered by Ruby Chat 0.1.1 © 2008, Jewelry Сase Team


Возможности и лог изменений

Версия 0.1.1

Исправлено:

• Антимат и проверка на недопустимое имя, например "admin" (фильтровал Слово, но пропускал СЛово).
• Антифлуд админская часть (не устанафливал тайм-аут по "просьбе" админа).
• Баги, возникающие при неудачном определени ip (админская часть).
• Уязвимость при переходе из админке в чат.
• Разные мелочи.

Добавлено:

• Опция отключения ротации банеров.

Версия 0.1.0

Возможности:

• Ограничение по длине сообщения и разбивка длинного сообщения на маленькие.
• Любителям аськи: отправка по "Ctrl+Enter".
• Обращение к собеседнику и цитирование по клику (соответственно по нику или сообщению). Адресат при этом видит у фразы стрелочку, означающую, что к нему обратились по нику.
• Авто-высота поля чата в зависимости от высоты окна браузера - отсутствие вертикальной полосы прокрутки окна чата, даже если пользователь его, окно браузера, уменьшил (в разумных пределах).
• Плавный автоскролинг и возможность его отключения.
• Звуковое уведомление о новом посетителе.
• Звуковое сопровождение смайлов (кроме Сафари).
• Запрет некоторых ников, например admin, причем учитывается подмена букв, например русской и латинской а, а так же учитываются похожие и одинаковые по написанию буквы из разных языков (символ H при наборе АДМИН)
• Антимат в сообщениях и никах(сторонний скрипт фильтра).
• Антифлуд (описание механизма работы).
• Синонимы для смайлов :-) и :)
• Разбиение длинных слов на короткие. При чем ссылки не бьются на слова по 50 знаков, а передаются действующей ссылкой. Ссылки должны начинаться с http:// или www.
• Кеширование некоторых запросов.
• Самоочищающаяся таблица последних сообщений.
• Смена цвета сообщение "на лету".
• Включение/выключение звуков.
• Админу: бан по ip, увеличение таймаута между сообщениями.
• Ротатор банеров. Принимаются картинки, тянущийся со стороны js, флэш.
• Перевод строк в сообщении. Максимально, для защиты от флуда, разрешено три перевода (или 4 строки).


Изменения, которые надо внести в скрипт для корректной работы на php 4

1. Правим .../ajaxscripts/Chat/users.php

После строки

echo (count($m1)-1);

вставляем код

function array_diff_key($array1, $array2) {
unset($mass);
foreach($array1 as $key => $val) {
if (!array_key_exists($key, $array2)) {
$mass[$key] = $val;
}
}
return $mass;
}

Если не помогло, замените все вхождения слова array_diff_key на что-то своё, например array_diff_key123


Выполнение запроса на создание таблиц

1. Зайдите в phpMyAdmin и выберете Вашу базу данных
2. Перейдите во вкладку SQL

3. Вставьте всё из файла __sql/txt.sql в поле "Выполнить запрос"
4. Жмем "OK" и продолжаем установку назад


Отблагодарить веб-мастера
и стимулировать его на дальнейшее
усовершенствование скрипта можно:

webmoney
Z208169104392
R176236280209
E278447567725
U529242209208

Яд
41001166446987